Repository navigation
Description
Vulnerable Library - js-18.0.4.tgz
Sample Path to Dependency File: /package.json
Path to vulnerable library: /package.json
Found in HEAD commit: 643acc098198f8640772d8a6ea35194839e4b4dc
Vulnerabilities
| Vulnerability | Severity | Dependency | Type | Fixed in (js version) | Remediation Possible** | |
|---|---|---|---|---|---|---|
| CVE-2026-44728 | 8.2 | plugin-transform-modules-systemjs-7.23.3.tgz | Transitive | 18.0.5 | ❌ | |
| CVE-2025-27789 | 6.2 | runtime-7.23.7.tgz | Transitive | 18.0.5 | ❌ |
**In some cases, Remediation PR cannot be created automatically for a vulnerability despite the availability of remediation
Details
CVE-2026-44728
Vulnerable Library - plugin-transform-modules-systemjs-7.23.3.tgz
Library home page: https://registry.npmjs.org/@babel/plugin-transform-modules-systemjs/-/plugin-transform-modules-systemjs-7.23.3.tgz
Sample Path to Dependency File: /package.json
Path to vulnerable library: /package.json
Dependency Hierarchy:
- js-18.0.4.tgz (Root Library)
- preset-env-7.23.7.tgz
- ❌ plugin-transform-modules-systemjs-7.23.3.tgz (Vulnerable Library)
- preset-env-7.23.7.tgz
Found in HEAD commit: 643acc098198f8640772d8a6ea35194839e4b4dc
Found in base branch: main
Vulnerability Details
Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.
Publish Date: 2026-05-26
URL: CVE-2026-44728
CVSS 3 Score Details (8.2)
Base Score Metrics:
- Exploitability Metrics:
- Attack Vector: Local
- Attack Complexity: Low
- Privileges Required: Low
- User Interaction: Required
- Scope: Changed
- Impact Metrics:
- Confidentiality Impact: High
- Integrity Impact: High
- Availability Impact: High
Suggested Fix
Type: Upgrade version
Origin: GHSA-fv7c-fp4j-7gwp
Release Date: 2026-05-09
Fix Resolution (@babel/plugin-transform-modules-systemjs): 7.29.4
Direct dependency fix Resolution (@nx/js): 18.0.5
Step up your Open Source Security Game with Mend here
CVE-2025-27789
Vulnerable Library - runtime-7.23.7.tgz
Library home page: https://registry.npmjs.org/@babel/runtime/-/runtime-7.23.7.tgz
Sample Path to Dependency File: /package.json
Path to vulnerable library: /package.json
Dependency Hierarchy:
- js-18.0.4.tgz (Root Library)
- ❌ runtime-7.23.7.tgz (Vulnerable Library)
Found in HEAD commit: 643acc098198f8640772d8a6ea35194839e4b4dc
Found in base branch: main
Vulnerability Details
Babel is a compiler for writing next generation JavaScript. When using versions of Babel prior to 7.26.10 and 8.0.0-alpha.17 to compile regular expression named capturing groups, Babel will generate a polyfill for the ".replace" method that has quadratic complexity on some specific replacement pattern strings (i.e. the second argument passed to ".replace"). Generated code is vulnerable if all the following conditions are true: Using Babel to compile regular expression named capturing groups, using the ".replace" method on a regular expression that contains named capturing groups, and the code using untrusted strings as the second argument of ".replace". This problem has been fixed in "@babel/helpers" and "@babel/runtime" 7.26.10 and 8.0.0-alpha.17. It's likely that individual users do not directly depend on "@babel/helpers", and instead depend on "@babel/core" (which itself depends on "@babel/helpers"). Upgrading to "@babel/core" 7.26.10 is not required, but it guarantees use of a new enough "@babel/helpers" version. Note that just updating Babel dependencies is not enough; one will also need to re-compile the code. No known workarounds are available.
Publish Date: 2025-03-11
URL: CVE-2025-27789
CVSS 3 Score Details (6.2)
Base Score Metrics:
- Exploitability Metrics:
- Attack Vector: Local
- Attack Complexity: Low
- Privileges Required: None
- User Interaction: None
- Scope: Unchanged
- Impact Metrics:
- Confidentiality Impact: None
- Integrity Impact: None
- Availability Impact: High
Suggested Fix
Type: Upgrade version
Origin: GHSA-968p-4wvh-cqc8
Release Date: 2025-03-11
Fix Resolution (@babel/runtime): 7.26.10
Direct dependency fix Resolution (@nx/js): 18.0.5
Step up your Open Source Security Game with Mend here
Activity
[-]js-18.0.4.tgz: 1 vulnerabilities (highest severity is: 7.5)[/-][+]js-18.0.4.tgz: 1 vulnerabilities (highest severity is: 7.5) - autoclosed[/+]mend-bolt-for-github commentedon Nov 19, 2024
✔️ This issue was automatically closed by Mend because the vulnerable library in the specific branch(es) was either marked as ignored or it is no longer part of the Mend inventory.
[-]js-18.0.4.tgz: 1 vulnerabilities (highest severity is: 7.5) - autoclosed[/-][+]js-18.0.4.tgz: 1 vulnerabilities (highest severity is: 6.2)[/+][-]js-18.0.4.tgz: 1 vulnerabilities (highest severity is: 6.2)[/-][+]js-18.0.4.tgz: 2 vulnerabilities (highest severity is: 8.2)[/+][-]js-18.0.4.tgz: 2 vulnerabilities (highest severity is: 8.2)[/-][+]js-18.0.4.tgz: 2 vulnerabilities (highest severity is: 8.2) - autoclosed[/+]mend-bolt-for-github commentedon Oct 22, 2026
ℹ️ This issue was automatically closed by Mend because it is a duplicate of an existing issue: #171